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	Submit your assignment to the Dropbox located on the silver tab at the top of this page. 
(See Syllabus/"Due Dates for Assignments & Exams" for due dates.)



	
	i L A B  O V E R V I E W 
	



	Scenario/Summary


You have been asked to help Dr. Dinewell, a local nutrition specialist, create a website that provides information on nutrition and healthy eating to the public. Dr. Dinewell is providing this educational site as a service to the community, and also to promote awareness of her nutritional consulting practice. 
Dr. Dinewell wants the site to include the following features: 
· A home page with an introduction, some information about her consulting practice, and links to the other pages on the site. 

· A Body Mass Index calculator that allows visitors to enter their height and weight and determines if they are underweight, normal, overweight, or obese. Dr. Dinewell wants the BMI calculator to be available through a web browser and also through an application that visitors can use on a Smartphone or other mobile device, so that they can check their BMI on the go. 

· A Daily Calorie Needs calculator that allows visitors to determine how many calories they need to consume each day to maintain their weight. 

· A page that allows visitors to search for popular foods and display how many calories they contain, to help them manage their calorie intake. 

· A form that allows Dr. Dinewell to maintain the information on the calorie content of foods by adding, modifying, or deleting food records as needed. This form should be protected by a user name and password so that only Dr. Dinewell can access it. 

· A page where visitors can enter their e-mail addresses to sign up for Dr. Dinewell's nutrition newsletter. After entering their e-mail addresses, visitors should receive an automatic e-mail message confirming that they are signed up for the newsletter. 
Fortunately, you do not have to do all of this at once! At this time, you will just create the style sheet and home page for the site. The other elements will be added in future weeks. 
	Deliverables


 
1. Healthy Eating website on the Web server containing the following files:
· Home page (Default.htm) 
· Style sheet (StyleSheet.css) 
· Logo image (HealthyEatingLogo.png) 
2. Word document with screen shot of home page displayed in browser (Your Name BIS450 Lab1 Screenshot.docx). Screen shot must show the complete browser window, including the URL of the page. 
	Grading Rubric


 
	Criteria
	Points
	%

	Step 2: Add Logo Image to Site (HealthyEatingLogo.png) 
· Logo image file uploaded to your Web folder 
	1
	4%

	Step 3: Create Home Page (Default.htm) 
· Default.htm created in your Web folder 
· Page header 
· Navigation menu with six links 
· Main section with two paragraphs of text 
· Page footer with disclaimer and copyright 
	10
	40%

	Step 4: Create Style Sheet (Style Sheet.css) 
· StyleSheet.css created in your Web folder 
· Body style – 16px Arial font 
· #header style – x-large bold font, 95px line height, 95px indent, logo as background image with no repeat, solid medium light green bottom border 
· #nav style – light blue background color, centered text, 5px top and bottom padding 
· #main style – 10 px top and bottom padding 
· #footer style – x-small font, centered text, solid thin light green top border 
	6
	24%

	Step 5: Format Home Page (Default.htm) 
· Styles from StyleSheet.css applied to home page 
· Hippocrates quote in italics 
	2
	8%

	Step 6: Add Navigation Links to Home Page (Default.htm) 
· Home → Default.htm 
· BMI Calculator → BmiCalc.aspx (file doesn't exist yet) 
· Calorie Needs → CalNeeds.aspx (file doesn't exist yet) 
· Food Info → FoodInfo.aspx (file doesn't exist yet) 
· Newsletter → Signup.aspx (file doesn't exist yet) 
· Admin → Secure/Admin.aspx (file doesn't exist yet) 
	3
	12%

	Step 7: Preview in Browser, Capture Screenshot and Submit (Student Name BIS450 Lab1 Screenshot.docx) 
· Word document with screenshot of Home page in browser submitted to Week 1 iLab Dropbox 
	3
	12%

	Total
	25
	100%



	
	i L A B  S T E P S 
	



	PREPARATION
	


1. Download the file BIS450 Lab1 Homepage.txt from the iLab Files folder in Doc Sharing and save it in your working folder for this iLab. 
2. Download the image file HealthyEatingLogo.png from the iLab Files folder in Doc Sharing and save it in your working folder for this iLab. 
3. Using the Citrix remote lab: 
a. Follow the login instructions located in the iLab tab in Course Home. 
b. Create a folder on your remote drive named BIS450Labs.
c. Upload the files you downloaded from Doc Sharing into the BIS450Labs folder. 
	STEP 1: Create Website on the DeVry Web Server
	


1. Launch Microsoft Visual Studio 2010. 
You must use Visual Studio 2010 in the Citrix environment. 
2. Pull down the File menu and select Open, then select Web Site. In the Open Web Site dialog, select FTP Site in the left column. 
a. For Server, enter bisweb.devry.edu. 
b. For Port, make sure 21 is entered. 
c. For Directory, enter coursefolder/yourname, replacing coursefolder with the name of the folder on the web server for your course (which will be provided by your professor), and replacing yourname with your first initial and last name, (e.g., jsmith for student John Smith). Uncheck Passive Mode and Anonymous Login. 
d. For Username, enter acad\D#, where D# is your eight-digit DSI number. 
e. For Password, enter the same password as you use for the iLab. Click Open.

NOTE:  The screen shot below is an example.  Use the information provided in a. thru e. above and the “Directory” name (c) provided by your instructor.
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\1.jpg]bisweb.devry.edu

3. After a pause, you should see the empty Website appear in the Solution Explorer pane in Visual Studio, as shown below. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\2.jpg]
TIP: If you don't see the Solution Explorer in your Visual Studio window, pull down the View menu and click Solution Explorer.
	STEP 2: Add Logo Image to Site
	


1. Pull down the Website menu and click Add Existing Item. 
2. In the Add Existing Item dialog, navigate to where you saved the HealthyEatingLogo.png file that you downloaded from Doc Sharing. (If you are working on the Citrix iLab server, and you saved the file on your local computer, remember that your local computer's disk drives are the ones with dollar signs $.) In the dropdown list in the lower right corner of the Add Existing Item dialog, select All Files (*.*). In the file list, select the HealthyEatingLogo.png file and click Add. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\3.jpg]
The image file will be added to the site and should now appear in Solution Explorer. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\4.jpg]
	STEP 3: Create Home Page
	


1. Pull down the Website menu and click Add New Item, or click the Add New Item button on the toolbar. 
2. In the Add New Item dialog, select the HTML Page template. Change the Name to Default.htm (a standard name for the home page on Windows-based sites). Click Add.
[image: ]
3. A new Default.htm page should be added to the site in Solution Explorer and automatically opened in Source view, as shown below.
[image: ]
TIP: It is OK if you do not see line numbers on the left side of your Source view editing window. This is an option that can be turned on or off in Visual Studio. If you want to see line numbers, pull down the Tools menu and select Options; then in the Options dialog box, select Text Editor > All Languages > General and place a check in the Line numbers option.
4. Click the Design tab below the editing window to switch to Design View. 
5. If necessary, open the Toolbox on the left by hovering the cursor over it, and expand the HTML section by clicking the small + sign beside HTML. In the HTML section of the Toolbox, double-click the Div item to add a div to the page. The editing window should look like this after the div has been added: 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\7.jpg]
6. Make sure that the DIV item is selected on the page and right-click and select Properties to open the Properties window. For the (Id) property type in header, as shown.
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\8.jpg]
7. Select a location below the header Div and again double-click the Div item in the HTML section of the Toolbox to add a second div to the page. In the Properties window, enter nav as the (Id) property. 
8. Again select a location below the nav Div and again double-click the Div item in the Toolbox to add a third div to the page. In the Properties window, enter main as the (Id) property. 
9. Again select a location below the nav Div and again double-click the Div item in the Toolbox to add a fourth div to the page. In the Properties window, enter footer as the (Id) property. The page should now look like this:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\9.jpg]
10. Open the file BIS450 Lab 1 Homepage.txt that you downloaded from Doc Sharing. Select and copy just the first line, "Healthy Eating with Dr. Dinewell." In the Default.htm editing window, click inside the first (topmost) div (the one labeled #header), and paste in the line of text. 
11. Return to the BIS450 Lab 1 Homepage.txt file, and select and copy the second line of text that begins "Home | BMI Calculator . . . ." In the editing window for Default.htm, click inside the second div from the top (labeled #nav) and paste in this line. 
12. Return to the BIS450 Lab 1 Homepage .txt file, and select and copy the paragraphs that begin "Almost 2,400 years ago . . ." and "Dr. Dinewell is . . . " In the editing window for Default.htm, click inside the third div (labeled #main) and paste in these paragraphs. If necessary, click just before "Dr. Dinewell is . . . " and press the Enter key twice to create a blank line between the paragraphs. Also, click at the end of the last sentence of the second paragraph and press the Enter key to create a blank line at the end. Notice that the email address "DocDinewell@gmail.com" automatically changes to a link when you do this. 
13. Return to the BIS450 Lab 1 Homepage.txt file, and select and copy the last two paragraphs that begin "All information on this site . . . " and "(c) 2010 . . . ". In the editing window for Default.htm, click inside the bottom div (labeled #footer) and paste in these paragraphs. If necessary, click just before "(c) 2010 . . . " and press the Enter key twice to create a blank line between the paragraphs. 
14. Click the Source tab at the bottom of the editing window to switch to Source View. At the bottom of the page, delete the "(c)" in the copyright notice and replace it with the HTML character code ©, as shown:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\10.jpg]
TIP: If, at any time, you are having trouble getting the page to come out right, it may be easier to switch to the Source tab in the editing window and fix the problem by editing the HTML tags directly, rather than tinkering in the Design view. 
15. Click the Design tab below the editing window to return to Design View. Your page now should look like the following:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\11.jpg]
16. Click the Save button (floppy disk icon) on the toolbar to save your work so far. 
	STEP 4: Create Style Sheet
	


1. Pull down the Website menu and click Add New Item, or click the Add New Item button on the toolbar. 
2. In the Add New Item dialog, select the Style Sheet template. Accept the default name of StyleSheet.css and click Add. 
[image: ]
The new style sheet, containing an empty style rule for the body tag, is added to the site and appears in the editing window. 
[image: ]
3. Make sure the cursor is positioned anywhere in the body { } style rule. Pull down the Styles menu and select Build Style. In the Modify Style dialog, select the Font category. For font-family, select the entry for Arial, Helvetica, sans-serif from the drop-down list. For font-size enter 16, and make sure that px (for pixels) is selected in the associated drop-down list. Click OK.
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\14.jpg]
4. Pull down the Styles menu and select Add Style Rule. In the Add Style Rule dialog, select the Element ID option and type in header. Click OK.
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\15.jpg]
A new style rule for #header should be added immediately below the body style rule, as shown:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\16.jpg]
5. Making sure the cursor is positioned inside the new #header style rule, pull down the Styles menu and select Build Style. In the Modify Style dialog, select the Font category, then set font-size to x-large and font-weight to bold.
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\17.jpg]
Select the Block category. Enter 95 for the line-height, and make sure px (for pixels) is selected in the associated drop-down list. Also enter 95 for text-indent, again making sure that px is selected in the associated drop-down. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\18.jpg]
Select the Background category. For the background-image, click on the Browse button. In the Picture dialog, under Contents of folder on the right, select the HealthyEatingLogo.png file and click OK.
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\19.jpg]
Back in the Modify Style dialog, for background-repeat, select no-repeat from the drop-down list. The Background section of the Modify Style dialog should now look like this:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\20.jpg]
Select the Border category, uncheck all three Same for all checkboxes, and on the row labeled bottom, select solid as the border-style, select medium as the border-width, and type in #B2FF4C as the border-color. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\21.jpg]
Click OK. 
6. Pull down the Styles menu and select Add Style Rule. Select the Element ID option and type in nav, then click OK. A new style rule for #nav will be added to the style sheet. 
7. Making sure that the cursor is positioned inside the #nav style rule, pull down the Styles menu and select Build Style. In the Modify Style dialog, select the Background category, and type in #BFDDFF as the background-color. Select the Block category and set text-align to center. Select the Box category, uncheck the Same for all checkbox for Padding, and enter 5 for top and bottom (making sure that the associated drop-down lists are set to px for pixels). Click OK. 
8. Pull down the Styles menu and select Add Style Rule. Select the Element ID option, type in main, and then click OK. A new style rule for #main will be added to the style sheet. 
9. Making sure the cursor is positioned inside the #main style rule, pull down the Styles menu and select Build Style. In the Modify Style dialog, select the Box category, uncheck the Same for all checkbox for padding, and enter 10 for top and bottom (making sure that the associated drop-down lists are set to px for pixels). Click OK. 
10. Pull down the Styles menu and select Add Style Rule. Select the Element ID option and type in footer, then click OK. A new style rule for #footer will be added to the style sheet. 
11. Making sure the cursor is positioned inside the #footer style rule, pull down the Styles menu and select Build Style. In the Modify Style dialog, select the Font category, then set font-size to x-small. Select the Block category and set text-align to center. Select the Border category and uncheck all three Same for all checkboxes. On the row labeled top:, select solid as the border-style, select thin as the border-width, and type in #B2FF4C as the border-color. Click OK. 
Your style sheet now should look like the following:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\22.jpg]
12. Click the Save button (floppy disk icon) on the toolbar to save your work so far. 
	STEP 5: Format Home Page
	


1. Click on the Default.htm tab to display the home page file in the editing window. Pull down the Format menu and select Attach Style Sheet. In the Select Style Sheet dialog, under Contents of folder on the right, select StyleSheet.css and click OK. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\23.jpg]
The styles you defined previously will now be applied to the page. 
2. Highlight the Hippocrates quotation "Let food be thy medicine." Pull down the Format menu, select Font…, select the Italic Font style, and click OK; or just press Ctrl+I. 
Your page should now look like the following:
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\24.jpg]
3. Click the Save button (floppy disk icon) on the toolbar to save your work so far. 
	STEP 6: Add Navigation Links to Home Page
	


1. In the second div from the top (labeled #nav), drag your cursor across the word "Home" to highlight it. Pull down the Format menu and click Convert to Hyperlink, or press Ctrl+L. In the Hyperlink dialog, click the Browse button. In the Select Project Item dialog, under Contents of folder, select Default.htm and click OK. 
Click OK again in the Hyperlink dialog to complete the hyperlink. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\25.jpg]
2. Now highlight the words "BMI Calculator." Again pull down the Format menu and click Convert to Hyperlink, or press Ctrl+L. Because the page for this hyperlink doesn't yet exist (we'll be creating it in a future week), we will need to type in the name of the file instead of browsing to it. In the URL field, type BmiCalc.aspx. Click OK. 
3. Repeat the previous action to create hyperlinks for the remaining items on the navigation menu, as follows: 
· Calorie Needs URL: CalNeeds.aspx 
· Food Info URL: FoodInfo.aspx 
· Newsletter URL: Signup.aspx 
· Admin URL: Secure/Admin.aspx 
4. The top part of your Default.htm page should now look like the following: 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\26.jpg]
5. Click the Save button (floppy disk icon) on the toolbar to save your work so far.

	STEP 7: Preview in Browser, Capture Screenshot, and Submit
	


1. To preview your Default.htm web page in the browser, in the Solution Explorer window, right-click on Default.htm and select View in Browser. 
2. If you see a "Web Site URL Required" message, copy and paste the complete Web address from the Website: field on the top into the URL: field on the bottom, change the "ftp:" to "http:", and click OK. You should do this any time this message appears during any lab in this course. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\note.gif]The image below was captured in a test environment, so the addresses look different from yours. You will use the web address containing your course folder and your personal folder. Copy and paste the address from your Website: field; don't type in the address shown below. 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\27.jpg]
If you accidently enter the incorrect URL, you will need to perform the following actions: 
a. Go to the Solution Explorer. 
b. Select the FTP server location listed.
c. Right-click and select Start Options… 
d. In the Server section, set the Base URL to the correct http:// location as described above. 
3. A new browser window should open and display your Default.htm page. It should look similar to the following: 
[image: C:\Users\Ruminari\Desktop\Downloads\BIS450 old iLab 1 12-7-11_files\28.jpg]
TIP: If you make a change in the editing window (either in Design or Source view), you must save your work and then refresh the browser window for the change to show up in your browser. 
4. Press Alt+PrintScreen on your keyboard to capture a screen shot of your finished Default.htm page displayed in the browser window. 
5. Open a new Word document and paste your screen shot into it. Make sure that the complete browser window, including the URL, can be seen in the screen shot. 
6. Save your Word document as Your Name BIS450 Lab1 Screenshot.docx, (replacing Your Name with your actual name, e.g. "Smith, John",) and submit it to the Week 1 iLab Dropbox. 
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tailored eating plans that are based on the latest medical Study results as well as her 25 years of

experience. To arrange a personal consultation, please call 562-555-1234 o email
inewell@qmail.com
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